[7.0] xorg 7.3 and ati/radeon 6.8.0 woes

Torgeir Hoffmann twhoffma at student.matnat.uio.no
Mon Mar 10 23:17:49 UTC 2008


after upgrading my IBM T42 with ati radeon M10/9700) to 7-release via
freebsd-update (which went very well), and running portsnap+portupgrade
-afP, I tried starting xorg.

This results in a complete freeze of the machine, no Ctrl-Alt-Backspace,
Ctrl-Alt-Delete, changing terminals or anything else works.

I can start xorg as root with the 'vesa' driver. However, any config in
xorg.conf with the 'ati'/'radeon' driver causes a freeze. Mostly, it will
freeze with either a black screen (backlight on), or simply freeze after

(==) Using config file: "/etc/X11/xorg.conf".

I have tried disabling glx, dri, setting NoAccel and AGPMode to "1".
Nothing seems to work.

The funny thing is that neither /var/log/messages or /var/log/Xorg.0.log
has any mention at all of any problems, let alone that I even started

Also, using xorg 7.2/7.3 in 6.2-release and 6.3-release did not seem to
cause any problems. I am at loss to what would be the cause.

Will gladly post xorg.conf (generated by Xorg -configure, changed
keyboard), and any logs necessary.

Hope for quick reply,

Best Regards,


More information about the freebsd-questions mailing list