WLan randomly suffering from heavy package lost

Luca Presotto presotto at mail.cern.ch
Sun Mar 9 14:53:08 UTC 2008

Hi everyone.
I'm currently running  freebsd-7.0-release GENERIC on a dell Inspiron 6400 
I have a problem when networking via wifi. I have an intel 3945abg 
integrated card and I'm using the wpi drivers.
I can connect to my wlan but after one minute or so of perfect 
connection the network starts to be terribly slow. I have tried pinging and I discovered that I have a 60% 
package lost when pinging something like google or other sites, that goes  
up to 90% or more when I increase the package size.
When pinging my router or other computers inside my network I get even 
worse performances. (Something like 97% package lost or 100% if increasing 
the package size to something like 1400)
With other OSes in my pc everything is fine, other pcs connect without 
problem. If I connect via etherneth to the same hub where the wifi 
transmitter is connected everything is fine.
I have tried adding to resolv.conf, automatically generated by dhclient, 
the addresses of the DNSs of my ISP and 
browsing the internet has become a liiitle better, but still very far from the 
normal speed. And connecting to other pcs inside my network is still a 

Any idea?

Thank you, 

resolve .conf:

nameserver (my router)
nameserver .......(my ISP DNS)

#ifconfig wpi0
wpi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:1b:77:23:a3:9e
        inet6 fe80::21b:77ff:fe23:a39e%wpi0 prefixlen 64 scopeid 0x1 
        inet netmask 0xffffff00 broadcast
        media: IEEE 802.11 Wireless Ethernet autoselect (OFDM/24Mbps)
        status: associated
        ssid Maldives channel 6 (2437 Mhz 11g) bssid 00:11:95:18:83:45
        authmode OPEN privacy OFF txpower 50 bmiss 7 scanvalid 60
        protmode CTS

More information about the freebsd-questions mailing list