Lib Errors After 6.3 - 7 Update

Kris Kennaway kris at
Tue Mar 4 21:20:57 UTC 2008

Dimitri Yioulos wrote:
> On Tuesday 04 March 2008 3:32 pm, Robert Davison wrote:
>> I've tried to update 6.3 to 7 using the sh -f
>> freebsd-update.conf -r 7.0-RELEASE upgrade process. I thought all had gone
>> well untill I started getting lib-XXX.so4 missing file here and
>> missing there. I'm guessing that the update process has deleatd some shared
>> libararies which are still required.
>> I have the files in question, but instead of, the file is called
>> I followed the instructions to the 'T' but nothing seems to work i.e
>> MailScanner, apache etc.
>> I've tried portupgrade -af to see if I can link the ports to the new lib
>> files, but alas nothing.
>> Anyone got any ideas??
> Perhaps someone has a better suggestion for you, but I had a similar issue 
> with regard to installing VMware Tools.  In my case, I symlinked 
> linked to, and the VMware Tools installation proceeded.

Ah yes, I forgot about bogus advice option 2 :-)


More information about the freebsd-questions mailing list