Can't load kernel, trying to install on a Dell R900.

tomasz dereszynski tomaszd at
Thu Feb 28 14:53:45 UTC 2008

Nicky Bulthuis wrote:
> Mel wrote:
>> On Thursday 28 February 2008 12:51:10 Nicky Bulthuis wrote:
>>> I'm having 'a lot' of troubles installing FreeBSD on a new Dell R900
>>> from CD. Somehow it just doesn't seem to be able to load the kernel
>>> from
>>> the CD.
>>> The machine is turned on with the CD is inserted.
>>> It shows the message of the BTX Loader and then it stops with an error
>>> message:
>>> can't load 'kernel'
>>> At first i figured my CD was broken, so i used a different image. Still
>>> no dice, same error message. I've tried 6.2 (amd64), 6.3 (amd64) and
>>> 7.0
>>> (amd64), sadly none of them work.
>>> I've disabled the internal CDrom drive and used an external USB CDrom
>>> drive. I figured, perhaps the internal cdrom drive is incompatible with
>>> FreeBSD. Sadly that also didn't work.
>>> Output from lsdev:
>>> cd devices:
>>>     cd0: Device 0x0
>>> disk devices:
>>>     disk0: Bios drive C:
>> What does ls / give? And ls -l /boot/kernel/kernel?
>> Been a while since I loaded a kernel manually, but I think:
>> boot -v cd0:/boot/kernel/kernel
>> should do the trick.
>> Does any of that give more hints to what might be the problem?
> Well, i've made some progress with your suggestions.
> First things first, i had already updated the BIOS from version 1.1.0
> to 1.1.3, the latest i could find on the Dell website.
> "ls /" and "ls -l /boot/kernel/kernel" both give me 'bad path'.
> "boot -v cd0:/boot/kernel/kernel" gives two messages, "can't boot
> kernel" followed by "no bootable kernel"
> Using 'ls cd0:/' gives me the cdrom file listing, so that works. I can
> browse the cdrom directory structure.
> I've done 'load cd0:/boot/kernel/kernel', which actually loads the
> kernel.
> I get the 'text[memadres] data[memaddress] syms[memaddress]' messages,
> and 'lsmod' shows me a loaded kernel.
> however, running 'boot -v' doesn't seem to work. It shows me the
> progressbar "|-/\", make a full circle, but stops right after.
you sure there is not option in bios about supported systems or something?
ive seen exactly the same problem with OpenBSD on HP boxes and you have
to disable one option in bios (can find out how is it called but its HP
not DELL) and then it works just fine

if you are 100% sure it is nothing to do with bios then sorry for
bothering you with my ideas.

bEsT rEgArDs		|	"Confidence is what you have before you
tomasz dereszynski	|	understand the problem." -- Woody Allen
Spes confisa Deo	|	"In theory, theory and practice are much 
numquam confusa recedit	|	the same. In practice they are very 
			|	different." -- Albert Einstein 

More information about the freebsd-questions mailing list