Can't load kernel, trying to install on a Dell R900.

Mel fbsd.questions at
Thu Feb 28 13:52:01 UTC 2008

On Thursday 28 February 2008 12:51:10 Nicky Bulthuis wrote:
> I'm having 'a lot' of troubles installing FreeBSD on a new Dell R900
> from CD. Somehow it just doesn't seem to be able to load the kernel from
> the CD.
> The machine is turned on with the CD is inserted.
> It shows the message of the BTX Loader and then it stops with an error
> message:
> can't load 'kernel'
> At first i figured my CD was broken, so i used a different image. Still
> no dice, same error message. I've tried 6.2 (amd64), 6.3 (amd64) and 7.0
> (amd64), sadly none of them work.
> I've disabled the internal CDrom drive and used an external USB CDrom
> drive. I figured, perhaps the internal cdrom drive is incompatible with
> FreeBSD. Sadly that also didn't work.
> Output from lsdev:
> cd devices:
>     cd0: Device 0x0
> disk devices:
>     disk0: Bios drive C:

What does ls / give? And ls -l /boot/kernel/kernel?

Been a while since I loaded a kernel manually, but I think:
boot -v cd0:/boot/kernel/kernel
should do the trick.

Does any of that give more hints to what might be the problem?

Problem with today's modular software: they start with the modules
    and never get to the software part.

More information about the freebsd-questions mailing list