diskLabelCommit fails within a sysinstall script?

Jerry McAllister jerrymc at msu.edu
Tue Feb 19 21:36:58 UTC 2008

On Tue, Feb 19, 2008 at 03:45:25PM -0500, Jeff Gold wrote:

> I am attempting to partition a disk non-interactively using
> sysinstall, but I don't seem to be getting this right.  I use the
> following script on an 80G drive:
>   debug=true
>   ufs=/6.2-RELEASE
>   mediaSetUFS
>   disk=ad0
>   partition=all
>   bootManager=boot
>   diskPartitionEditor
>   diskPartitionWrite
>   ad0s1a=ufs 1048576 /
>   ad0s1b=swap 4194304 none
>   ad0s1d=ufs 2097152 /tmp
>   ad0s1e=ufs 16777216 /usr
>   ad0s1f=ufs 0 /var 1
>   diskLabelEditor
>   diskLabelCommit
>   shutdown
> This runs without any evident error, but the relevant contents of /dev
> change from just ad0 to ad0, ad0s1 and ad0s1c.  The first two make
> sense but ad0s1c is the only device I didn't request.  None of the
> ones I did seem to appear.  A boot loader does seem to have been
> installed but when I select "F1" for FreeBSD it says "Invalid
> partition" and complains that there's "No /boot/loader" to be found.
> So I guess the first stage got installed but not the next one?
> Can anyone explain why this doesn't work?  I skipped the 'c' partition
> because that's what sysinstall wants to do when I run it
> interactively, but renaming the devices to include the 'c' makes no
> difference.  There is still an s1c and nothing else.  Also, I tried
> the syntax in the man page (ad0s1-1 instead of ad0s1a) but that --
> perversely -- gives me a bunch of errors about being unable to mount
> partitions with the other style names.

I don't know about all you ask, but the 'c' partition should always
be there and be set to identify the whole slice eg start at 0 and
the size be the size of the slice.   The system uses it to identify
some internal information about the slice.    

Sysinstall should handle that correctly just fine.   
I don't know why you do not get ad0s1a, swap, ad0s1d, etc.
Maybe, if you deleted that special 'c'  partition, it made
the rest of the process screw up.   


>                                                                     Jeff
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list