named executables not found in my box ; (Copied it from another machine)ut few Questions :

kkchn sms at
Mon Feb 18 08:30:13 UTC 2008

People:   please excuse me , but I tried another attempt to fix the issue

(I have installed the OS from the ISO image from which I installed
another box there named is running fine , but unfortunately in this
box its not running ), I can't trace it what went wrong ?

 Named is not starting , named forcestart I tried but no use ,

later I found that  ther is no executables  as /usr/sbin/named

&& /usr/sbin/rndc  & rndc-confgen  also not found  in this server box

whats went wrong with this box ?all named dirs & files there execpt
/usr/sbin/named   & rndc  executables :!!!!

So how can I rebuild/reinstall this named services in this FreeBSd6.2 box   ,

Expecting your valuable comments to fix this issue :

 Your Kind attention to the following section : most important  (
After a few days effort to fix this issue , I became desperate and
done an attempt as follows )

 : I made an attempt(Foolish ?I dont know if so please tell me :) ) to
make named running in this  box : what I did was   I copied the
/usr/sbin/named executables from my freeBSD-6.2 Desktop-PC to this
slave DNS
 server machines's  /usr/sbin dir

and done the following

[root at sun /home/dhanesh]# /etc/rc.d/named forcestart
rndc-confgen: not found       ///// (HERE it  compalined about   r n d c   :
I haven't copied rndc & rndc-confgen  from my Desktop -PC ;what they will
do  ? I mean  both  rndc & rndc-confgen?   is rndc & rndc-confgen  necessary
for a DNS server ? then I can copy these two files also)  //////
Starting named.
[root at sun /home/dhanesh]# sockstat -4p 53   ///  here after copying named
exe & and doing named forcestart  I found its started working  output as
follows )  /////
bind     named      71340 20 udp4    *:*
bind     named      71340 21 tcp4    *:*
bind     named      71340 22 udp4          *:*
bind     named      71340 23 tcp4          *:*

[root at sun /home/dhanesh]# cd /etc/namedb  /// here this machine I configued
as a slave DNS and found that its pulled out the zone file form master zone
file from my primary DNS server ) ///
[root at sun /etc/namedb]# ls
PROTO.localhost-v6.rev  make-localhost          named.root
PROTO.localhost.rev     master                  slave
dynamic                 named.conf
[root at sun /etc/namedb]# cd slave/
[root at sun /etc/namedb/slave]# ls
db-kL66bE3v         //here I found a new
file(db-kL66bE3v)  created !!! what this new file ? it is an emty file too

[root at sun /etc/namedb/slave]#vi

 //shows me that my primary zone file automatically pulled here , I think
now this machine is working as a slave DNS   Server : ///

A Few Questions  I have to clarify  : Let me ask them to you

But my questiona are  the follows

Q no : Did you think this setup will work well as a slave DNS  Server
without any issues  ( I havn't copied rndc & rndc-confgen)   ?

Q no. 2  :    The step  I followed (copying /usr/sbin/named )  from another
machine to this server box , is it a right way ? will it make any issues in
future ?

Q no: 3  : I havn't copied  /usr/sbin/rndc  & /usr/sbin/rndc-confgen from
the other machine to this slave DNS server machine ? what the siginificance
og rndc and rndc-confgen ? I f I am not copying these 2 files will make any
issues in the working of this server as a slave DNS ?

Q no:4 :   Whats your advice copy the rndc & rndc executables also to this
machine and restart named service ?


what I did was absolutely wrong , so remove  what I have done so far , go
for a port installation of bind9 and try again?

thanks in advance

More information about the freebsd-questions mailing list