linux program only runs from /compat/linux/usr/lib

Chuck Robey chuckr at
Wed Feb 13 19:42:36 UTC 2008

Hash: SHA1

Steve Franks wrote:
> If I cd to /compat/linux/usr/lib, and start <nameless linux app>, it
> runs fine.  If I start it from any other location, I get
> /usr/lib/ : wrong ABI. So the app is finding the
> FreeBSD lib instead of the Linux one.  I tried putting
> /compat/linux/usr/lib at the very front of my path and it doesn't seem
> to fix it.  Brandelf looks correct (SRV4) for both the app, and
>  So, how does FBSD figure out what lib to grab, and
> why is it grabbing the wrong one?

Do you have the Linuxulator's (which sits in /compat/linux/etc)
set with the correct path(s), and NOT picking up the stuff in /usr/local?
I am not at all sure that's what's biting you, but it'd be one way to get
bitten.  There are parallel tools for Linux and for FreeBSD, and the
Linux one is supposed to stick a prefix of /compat onto it.

You could try using the Linux "ldd"program, it should only find the correct

Fear of what your suggest is why, a short whioe back, I tried waging a war
to get folks to move all their linux libs back into the /compat tree, so
this sort of confusion couldn't happen, but I can't honestly say if that's
really what bit you here or not.

> Steve
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

Version: GnuPG v2.0.4 (FreeBSD)
Comment: Using GnuPG with Mozilla -


More information about the freebsd-questions mailing list