Freebsd based server lacking chown command, where to get it.

Derek Ragona derek at
Tue Feb 12 16:54:09 UTC 2008

At 10:49 AM 2/12/2008, deepcore wrote:

> > <chown is in /usr/sbin/>
> >
>ok. I get that, and i found it
>I can, however not execute it.
>whenever i go to the usr/sbin and type "chown" i get
>chown: Command not found.
>i find this pretty strange as ls -l shows:
>-r-xr-xr-x 1 root wheel 6688 Jan 12 2007 chown
>shouldn't this mean that the file is excecutable by all?
>even tried to switch to root first (just executing su)
>What i am more specifically trying to do is change the ownership of all the
>directories and files on a specific disk, mounted as /mnt/moviedisk, to the
>user that is supposed to own them.
>Any surgestions? What am i doing wrong as i cannot execute the chown

Sounds like your path doesn't include /usr/sbin, or /usr/sbin or /usr is 
mounted without exec.

Have you tried executing with the complete path:


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the freebsd-questions mailing list