/bin/csh script in GELI partition crashes 6.3-STABLE

Roland Smith rsmith at xs4all.nl
Tue Feb 12 15:01:36 UTC 2008

On Tue, Feb 12, 2008 at 08:02:49AM -0600, Scott Bennett wrote:
>      I just set up a GELI partition for the first time a while ago (not
> counting the swap partition).  After initializing the GELI device file,
> filling it from /dev/random, running newfs, and copying over a couple of
> directory trees from another file system, I tried running a C-shell script
> in one of the bottom-level directories.  The script works fine in its
> original location, but after cd'ing to the new location and running it,
> the system immediately reboots.  Because this leaves most/all of the file
> systems marked dirty, fsck has to run on startup.  (I ran fsck by hand on
> the GELI partition.)
>      It does it every time, so it is certainly repeatable.  Is this a
> known problem?  Or is there some feature of GELI-encrypted file systems
> that is expected to have problems running scripts? 

My /home is a GELI encrypted partition. I've never had problems running
scripts from it, although my scripts are usually sh, not csh. 

What does the script do? Are you running it as root?

R.F.Smith                                   http://www.xs4all.nl/~rsmith/
[plain text _non-HTML_ PGP/GnuPG encrypted/signed email much appreciated]
pgp: 1A2B 477F 9970 BA3C 2914  B7CE 1277 EFB0 C321 A725 (KeyID: C321A725)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20080212/6825bb8e/attachment.pgp

More information about the freebsd-questions mailing list