rc.d scripts not being run at shutdown.

Lowell Gilbert freebsd-questions-local at be-well.ilk.org
Tue Feb 12 14:52:57 UTC 2008

RW <fbsd06 at mlists.homeunix.com> writes:

> On Mon, 11 Feb 2008 21:55:28 +0000
> RW <fbsd06 at mlists.homeunix.com> wrote:
>> On Mon, 11 Feb 2008 14:19:21 -0500
>> Lowell Gilbert <freebsd-questions-local at be-well.ilk.org> wrote:
>> > RW <fbsd06 at mlists.homeunix.com> writes:
>> > > I could imagine screwing-up the operation of rc.shutdown with a
>> > > syntax error, but I don't see how I could stop it being run at
>> > > all. As I understand it rc.shutdown is run from init if the file
>> > > exists.  init itself doesn't seem to have been modified recently,
>> > > so I'm out of ideas.
>> > 
>> > rc.subr and rc.conf will be sourced first, so errors in those could
>> > cause problems.  
>> That's a good point, but I just tried it with an rc.shutdown script
>> that contains only the touch statement, and the file wasn't touched
>> (and I have tried running the touch manually).
>> I should also add that this problem has survived a world+kernel
>> rebuild to 7.0-RC2, which included the use of mergemaster. All the
>> scripts under /etc should be the ones in the repository.
> And now I come to think about it, I was tinkering with a random number
> script at the exact time the entropy file was written-out, and I'm
> pretty certain I wrote it myself. That means I have no evidence that
> rc.shutdown has worked at all since I installed FreeBSD 7 in early
> December.

So rcorder isn't being run on rc.d either?  Weird; I can't see what
could cause that.

More information about the freebsd-questions mailing list