/bin/csh script in GELI partition crashes 6.3-STABLE

Scott Bennett bennett at cs.niu.edu
Tue Feb 12 14:03:25 UTC 2008

     I just set up a GELI partition for the first time a while ago (not
counting the swap partition).  After initializing the GELI device file,
filling it from /dev/random, running newfs, and copying over a couple of
directory trees from another file system, I tried running a C-shell script
in one of the bottom-level directories.  The script works fine in its
original location, but after cd'ing to the new location and running it,
the system immediately reboots.  Because this leaves most/all of the file
systems marked dirty, fsck has to run on startup.  (I ran fsck by hand on
the GELI partition.)
     It does it every time, so it is certainly repeatable.  Is this a
known problem?  Or is there some feature of GELI-encrypted file systems
that is expected to have problems running scripts?  (I do not know whether
the problem is limited to /bin/csh scripts.  After several crashes in just
a few minutes, I decided I had had enough of that for one night.)
     If anyone has seen this happen before, please let me know.

                                  Scott Bennett, Comm. ASMELG, CFIAG
* Internet:       bennett at cs.niu.edu                              *
* "A well regulated and disciplined militia, is at all times a good  *
* objection to the introduction of that bane of all free governments *
* -- a standing army."                                               *
*    -- Gov. John Hancock, New York Journal, 28 January 1790         *

More information about the freebsd-questions mailing list