rc.d scripts not being run at shutdown.

RW fbsd06 at mlists.homeunix.com
Mon Feb 11 21:55:33 UTC 2008

On Mon, 11 Feb 2008 14:19:21 -0500
Lowell Gilbert <freebsd-questions-local at be-well.ilk.org> wrote:

> RW <fbsd06 at mlists.homeunix.com> writes:

> > I could imagine screwing-up the operation of rc.shutdown with a
> > syntax error, but I don't see how I could stop it being run at all.
> > As I understand it rc.shutdown is run from init if the file
> > exists.  init itself doesn't seem to have been modified recently,
> > so I'm out of ideas.
> rc.subr and rc.conf will be sourced first, so errors in those could
> cause problems.  

That's a good point, but I just tried it with an rc.shutdown script
that contains only the touch statement, and the file wasn't touched
(and I have tried running the touch manually).

I should also add that this problem has survived a world+kernel rebuild
to 7.0-RC2, which included the use of mergemaster. All the scripts
under /etc should be the ones in the repository.

>Is anything showing up in the log?

No, just that it's rebooting and that syslog is exiting. On the
console I see the stuff that follows  the rc.shutdown, the diminishing
counters etc.

More information about the freebsd-questions mailing list