pxeboot, TFTP only, NFS MOUNT RPC error: 60, timeout

Rek Jed rekjed at gmail.com
Thu Feb 7 23:33:44 UTC 2008

Hi Erik,

> I wrote the howto refered to in other reply, it's a while ago I played 
> with this, but I have no reason to think that much has changed on the 
> 6.x branch, I have just tried 7.x and build of the loader this way fails.

I tried building it on 7.0-PRERELEASE and it builds fine for me.
Haven't tested if it works yet, but will do in a moment.

> When building the loader make sure that your source tree is clean and 
> /usr/obj is empty, or it won't work. I recall this puzzled me a long 
> time until I found the trick. I don't think it is enough to do make 
> clean.

Yes, I made sure that /usr/obj was empty.

> # cd /usr/src/sys/boot

Originally I was doing this on 6.2.  I tried it again on a freshly
installed 6.3-RELEASE just now.  I made sure /usr/obj was empty and
build pxeboot using the above method, then copied it over to my
jumpstart server.  Unfortunately this didn't work.  It sat there for a
bit, then trowed  "NFS MOUNT RPC error: 60" as usual and then sat there
forever (it never fetched the kernel).

I also tried building it like that:

# cd /usr/src/sys/boot

This builds fine.  I copied it to my jumpstart server and it booted from
tftp after approx 2 min. pause and the "NFS MOUNT RPC error: 60".  Can
anyone tell me whats the difference between -DLOADER_TFTP_SUPPORT=YES

I've been playing with thinbsd (http://www.thinbsd.org/) a while back.
It also boots from tftp without nfs and their boot loader works fine
(boots straight away).  Latest thinbsd is based on 5.4 so maybe it broke
in 6.x?  For a workaround I used pxeboot from thinbsd with my 6.3
jumpstart setup and it seems to work fine.  However this is quite dirty.



Thanks for the howto Erik, I found it really helpful.

More information about the freebsd-questions mailing list