pxeboot, TFTP only, NFS MOUNT RPC error: 60, timeout

Zinevich Denis link at ngc.net.ua
Thu Feb 7 21:30:56 UTC 2008

I tried with LOADER_TFTP_SUPPORT and LOADER_NFS_SUPPORT both enabled.
Also I tried with nfs disabled and tftp enabled. All was made under 6.2 
stable, i386 arch.
Only once i`ve got it working without timeout, but I could not repeat this.
I`ll be back to this question in about one or two month with 6.2 and 
amd64 arch, so may be I`ll discover something new.
> Zinevich Denis wrote:
>> It does not work. I`ve tried. But as I found in forums and mailing 
>> lists it randomly helps sometimes.
> Please don't top-post. I have a comment in 
> src/sys/boot/i386/loader/conf.c v1.26 (RELENG_7) saying:
> #error "Cannot have both tftp and nfs support yet."
> #endif
> So at least the intent is that NFS and TFTP are mutually exclusive. 
> Since the OP has both working at the same time, there's something 
> wrong. Which version are you using, and which architecture?
> I'm not really able to help you debug further, so I suggest filing a 
> PR if one doesn't exist already.
> Erik
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list