buildworld releng7 exterme performance loss

Jerry McAllister jerrymc at
Wed Feb 6 11:42:39 PST 2008

On Wed, Feb 06, 2008 at 08:22:16PM +0100, Frank Staals wrote:

> Frank Staals wrote:
> >Every 2 weeks or so I rebuild my sources on my laptop ( Dell Latitude 
> >D630 ). Last wednesday I wanted to update my system again since it was 
> >allready a couple of weeks ago I rebuilded my sources. There were no 
> >abnormalities during the build/install. But when I restarted my system 
> >the system performance was absolutely *horrible*. When I try typing 
> >anything in a terminal window the lag is about 20 seconds before the 
> >command even shows up. Switching ttys takes at least as long. When 
> >logging in remotely the performance is better; giving a random command 
> >through the ssh session sometimes even allows a command run on a 
> >local-console to run/finish ( or at least thats what the screen shows ).
> >
> >Even trying to shutdown the system using shutdown -p now doesn't have 
> >any effect: I get the message "System is going down NOW" but nothing 
> >realy happens, I just get my prompt back and I can continue entering 
> >commands. When I push the power-off button the system actually starts 
> >shutting down but it stops at "Writing entropy file ."  leaving my 
> >only choise to power off the system the hard way. When booting the 
> >system to single-user mode however it reacts normally and also 
> >shutting down works as it should
> >
> >Last 2 days I tried redownloading the sources from a different mirror 
> >( instead of ) to rule out 
> >outdated/corrupted sources. But I still get the same  behaviour. 
> >Gladly I still had my previous sources so I managed to restore my 
> >system in a working state. Those sources are from about 3 weeks ago. 
> >Does anyone know what could have caused this behaviour and how to fix 
> >it ? Below is some system information, however I'm not sure what I 
> >should provide to help out, if I should test something I'll gladly do.

Sounds like the system is spending a lot of time waiting for some
resource - I don't know which one[s].

Have you perused the system logs?   Can you be running out of memory
or swap space?  Is the system built with debugging turned on?

I'm not sure what else to suggest.


> >
> >Working system (sources from about 3 weeks ago, rebuilded today  ) :
> >
> >frank at Rena# uname -a
> >Feb  1 20:23:11 CET 2008     root@:/usr/obj/usr/src/sys/RENAKERNEL  i386
> >
> >dmesg:
> >
> >With today's  ( 1 frebruary 2008 ) sources  :
> >
> >frank at Rena# cat /root/uname
> >FreeBSD  7.0-PRERELEASE FreeBSD 7.0-PRERELEASE #0: Fri Feb  1 18:32:59 
> >CET 2008     frank at  i386
> >
> >dmesg:
> >
> >Kernel config used for both the builds :
> >
> >
> >
> Updated my sources again today. This time even build with a GENERIC 
> kernel but still the same result. Is there nobody who can help me with 
> this ?
> -- 
> -Frank Staals
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list