3ware array access lock up on 7.1-RC

Mel fbsd.questions at rachie.is-a-geek.net
Sat Dec 27 19:41:42 UTC 2008

On Friday 26 December 2008 08:12:49 Artem Kuchin wrote:
> I am not even sure that it is related to freebsd, but maybe someone could
> point out the problem.
> We wanted to upgrade our hosting server from
> FreeBSD 6.2, 3ware 8506-4LP SATA RAID, raid 5
> to
> FreeBSD 7.1 (RC for now), 9550SXU-4LP, raid 10
> We have tested the new installation on ASUS P5K WS motherboard
> with PCI-X slot while the server kept running.
> The server has Supermicro X5DPE-G2  (pretty old one, 2004).
> So, when everything was ready, i just took out the old controller and
> disks and installed the new controller and the array disks.
> The system booted up, but when i started very intense file operations
> the file
> system just froze. The weird thing is that any open program which does
> not use
> filesystem kept running fine. For example, i could type and edit in open
> ee editor,
> but copying progress bar in midnight commander just stood still. If i
> tried to save file
> or open file or do anything disk related from ee in another console the
> program froze too,
> apparently waiting for disk system to reply forever (i tried waiting for
> 20 minutes).
> I could even connect to ssh port, but it does not auth because sshd
> needs to read something
> from the disk.
> I put everything back into Asus P5K WS and tested it. Everything worked
> fine again.
> Any idea what might going on here?

OS bugs aside, a dead disk that keeps getting IO request explains all 
symptoms. Dead can also mean, faulty cable, buggy connector. I would expect 
the hardware raid controller to pick up on it though and remove it from the 


Problem with today's modular software: they start with the modules
    and never get to the software part.

More information about the freebsd-questions mailing list