No sound from snd_hda

Steve Franks franks at
Mon Dec 22 23:02:29 UTC 2008

On Mon, Dec 22, 2008 at 11:49 AM, Alexander Motin <mav at> wrote:
> Damian Gerow wrote:
>> I've got an Intel HDA device that is sort-of detected, but I get no sound
>> from it:
>> -----
>> FreeBSD Audio Driver (newpcm: 64bit 2007061600/amd64)
>> Installed devices:
>> pcm0: <HDA Conexant (Unknown) PCM #0 Analog> at cad 0 nid 1 on hdac0 kld
>> snd_hda [MPSAFE] (1p:1v/1r:1v channels duplex default)
>> pcm1: <HDA Conexant (Unknown) PCM #1 Analog> at cad 0 nid 1 on hdac0 kld
>> snd_hda [MPSAFE] (1p:1v/1r:1v channels duplex)
>> -----
>> The same device looked almost exactly the same on a 7.1-BETA build, but I
>> actually had audio output.
>> I've checked the mixer device, tried muting and unmuting various channels,
>> all to no avail.  The audio devices are created, and every program I've
>> tried opens them successfully, but I get no actual sound.
>> I've tried searching around, but I haven't been able to turn anything up.
>> Is there something I'm missing?  Something I should be doing that I'm not?
> You are missing new snd_hda man page reading. RTFM. :)
> 1) Read new man page;
> 2) Driver provides you two pcm devices for different purposes, so try to use
> both (as man page recommends);
> 3) If your system has several audio connectors - try all of them, they are
> not equal any more.
> 4) Boot with verbose logs enabled to get much more information about your
> codec and driver operation (as man page recommends);
> 5) Connexant audio codecs are rare, so send your verbose output to me, I
> would like to see it.
> --
> Alexander Motin
> _______________________________________________
> freebsd-current at mailing list
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at"

Should I be asking you about the old snd_hda?  I'm having this same
problem and ignoring it for some time (no sound), but on

6.4-STABLE #9: Sat Dec 13 18:25:36 MST 2008
root at

instead of current.  I read the warning:

     A few Hardware/OEM vendors tend to screw up BIOS settings, thus rendering
     the snd_hda driver useless, which usually results in a state where the
     snd_hda driver seems to attach and work, but without any sound.

In the man page, and I suspect that may be my problem.  Chipset is
Intel.  I played with the bios, but only got it to be worse (snd_hda
not detected at all).

[steve at aire ~]$ cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <Intel 82801G High Definition Audio Controller> at memory
0xfdff8000 irq 16 kld snd_hda [20071129_0050] (1p/1r/1v channels
duplex default)

Is there any further info that would help?  I've been limping along on
a usb dongle and it's a bit sad ;)


More information about the freebsd-questions mailing list