Firebird client fails port install

Da Rock rock_on_the_web at
Mon Dec 15 12:37:34 PST 2008

On Mon, 2008-12-15 at 14:29 -0500, Lowell Gilbert wrote:
> Da Rock <rock_on_the_web at> writes:
> > I'm trying to install php5-extensions (which includes firebird), but its
> > failing with an error code 1 on firebird20-client. It does mention
> > running make to build firebird, but not as root. So I've tried
> > everything to get this to work: running make as my wheel group user,
> > installing as a pkg instead.
> >
> > What could I be missing?
> >
> > (And before anybody asks: I ran portsnap fetch update twice yesterday -
> > and I did run the update. I've learnt my lesson from last time...)
> Unless you set variables to put the work directory somewhere non-standard,
> the ports system will try to do its building under each port's directory,
> which is normally not writable by regular users.  Similarly, installing a
> port (or a package, for the same reasons) normally requires root
> permissions for access to system directories and in many cases to let
> programs installed by ports run as special-purpose users.
> What is the reason you're trying to install ports as a different user?

Because the first stop error occurs and it says to run make to build
firebird, but it also says "Please do not build firebird as 'root'
because this may cause conflicts with SysV semaphores of running

More information about the freebsd-questions mailing list