Disk errors on installing FreeBSD 8.0 (solved)

Al Plant noc at hdk5.net
Sat Aug 9 02:22:09 UTC 2008

Julien Cigar wrote:
> Same problems for me with atapi CD/DVD drives (READ_BIG timeouts,
> etc) .. it works a bit better when dma is turned off, but then
> performances are very poor.
> On Thu, 2008-08-07 at 14:17 -1000, Al Plant wrote:
>> N.J. Thomas wrote:
>>> * "Snorre D. ?verb?" <snorre at overbo.no> [2008-08-07 15:29:11+0000]:
>>>> When I boot up with the installation DVD these error messages appear
>>>> on the screen.
>>>> ad1: FAILURE - READ_DMA status=51<READY,DSC,ERROR> error=84<ICRC,ABORTED> LBA=0055347
>>>> ad0: FAILURE - READ_DMA status=51<READY,DSC,ERROR> error=84<ICRC,ABORTED> LBA=0
>>>> etc
>>> I got the same exact errors trying to install 7.0-RELEASE on two
>>> different Dell boxes. One was 4 years old, the other was brand new (3
>>> months ago).
>>> Never was able to fix the problem. For the older one, I plugged in an
>>> external DVD drive and installed via that. For the other one, I
>>> installed via a mini-install disk, and then did a minimal network
>>> install.
>>> For the record, they both had SATA drives and the disks worked (and
>>> still work) fine after the OS was installed. It was just copying the
>>> base system off the CD that was causing errors.
>>> Thomas
>>> _______________________________________________
>>> freebsd-questions at freebsd.org mailing list
>>> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
>>> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"
>> ****************************************888
>>   Aloha,
>> I am getting the same errors as you guys with an intermittient BIG_read 
>> one occasionally. I've tried to install FreeeBSD CURRENT 8 and 7 release.
>> This is on a no name box with a bio board and 1100 cpu. I've had this on 
>> other boxes too and load IDE drives on a box that works with them and 
>> then put them in the box with errors and they work just fine.
>> Every thing gets recognized normally at  install time, but the size of 
>> the IDE drive a Fujutsu 20 gig. shows twice what it should be every time.
>> Dont know if this has anything to do with it, except if you change the 
>> size in installer it wont load anything.
>> Maybe one of the top level gurus on the list can help.

The suggestion to put the folloeing worked to clear my DMA error.

In: /boot/loader
Put: hw.ata.ata_dma=0 #disable IDE DMA

This allowed an uninterrupted boot.

Thanks for the suggestion.

~Al Plant - Honolulu, Hawaii -  Phone:  808-284-2740
   + http://hawaiidakine.com + http://freebsdinfo.org +
   + http://aloha50.net   - Supporting - FreeBSD 6.* - 7.* - 8.* +
   < email: noc at hdk5.net >
"All that's really worth doing is what we do for others."- Lewis Carrol

More information about the freebsd-questions mailing list