IBM eServer x225 - LSI 1030 SCSI - BTX Halted / infinite loop

Derek Ragona derek at
Tue Aug 5 20:15:29 UTC 2008

At 01:42 PM 8/5/2008, underligast wrote:
>I'm trying to install FreeBSD 7.0 on my "new" server, an IBM eServer x225
>The server/drives runs fine under windows 2003 and ubuntu server but the
>FreeBSD installation just halts.
>So far i've tried:
>CD: disk1 from 6.2, 7.0,
>CD: bootonly from 7.0
>Floppys: 7.0
>They all end the same, cds with an infinite loop of numbers, floppys with
>BTX Halted and a lot of numbers.
>int=0000000d    err=00000000    efl=00010006    eip=000219b2
>eax=000219ac    ebx=00000000    ecx=c0000080    edx=000587d8
>esi=0003e007    edi=00000000    ebp=0008fcbc    esp=00099c88
>cs=0008   ds=0010   es=0010   fs=0010   gs=0010   ss=0010
>cs:eip=0f 32 0d 00 01 00 00 0f-30 0f 20 e0 83 c8 30 0f
>        22 e0 b8 00 c0 03 00 0f-22 d8 0f 20 c0 0d 00 00
>ss:esp=90 95 00 00 00 80 fc 00-00 90 fc 00 07 e0 03 00
>        00 00 00 00 07 d0 03 00-00 00 00 00 cc 87 05 00
>BTX halted
>The only difference is when i boot from 7.0-STABLE-200804-i386-bootonly.iso,
>then i see
>BTX loader 1.00 BTX version is 1.02
>Consoles: internal video/keyboard
>BIOS CD is cd0
>BIOS drive A: is disk0
>Then it stops.
>If i remove both the harddrives i can boot into the freebsd installer, but
>as there are no drives, there is nowhere to install.
>Atleast when i started with the floppys it detected drive1 and 2 before BTX
>I dont know what to do anymore, there is just no way to get freebsd to
>install on this thing.
>Is it the LSI controller, it should still be initiated when there are no
>drives in it, and the installation starts fine then.
>Is it the Motherboard, the bios, the cpu, the ram? what?
>The disks, having just one in doesn't work, switching positions doesn't
>Does anyone have any idea on how i can proceed once i'm in the installation,
>can i mount the drives and install somehow?
>The hardware is:
>1x Xeon 2.8GHz(512KB), 2x 2048MB PC2100 DDR SDRAM (ecc), 2x 74GB 10K rpm
>U320 HDD, Ultra320 SCSI, 48x CD-ROM, Broadcom NetXtreme 10/100/1000
>Integrated Ethernet, ATI Rage XL

Obviously it is the SCSI card or drives.  Have you tried changing the BIOS 
settings on the SCSI?  You might want to try changing the SCSI BUS 
speed.  You may also want to try turning off hyperthreading.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the freebsd-questions mailing list