dump restore pain and suffering

Kevin Sanders newroswell at gmail.com
Mon Apr 21 15:12:17 UTC 2008

On Mon, Apr 21, 2008 at 1:58 AM, Dominic Fandrey <kamikaze at bsdforen.de> wrote:
> Kevin Sanders wrote:
> > I've been dumping and restoring a test system today, and I'm have very
> > little success.  Basically, I've been installing a base FreeBSD
> > 7-RELEASE/i386 system, doing something like dump -0auL -f
> > /mnt/test.root.dump, formating the drive and trying to restore -rf
> > /mnt/test.root.dump.  /mnt is a ufs formated usb drive.  After the
> > dump, I've even done a restore -rNf /mnt/test.root.dump just to make
> > sure it doesn't complain out the dump file.
> >
> > I've read the handbook, found a few articles, googled all the errors.
> > The header dumpdate thing is harmless, the expected next file is from
> > it being a live system, but I'm not ending up with a system that is
> > very usable.  Doing a df, I see that sometimes I end up with a
> > restored slice that is about the same size as my dump file, sometimes
> > less than half.  I know I'm not being very specific with what's not
> > working, but is anyone really using dump/restore and having success
> > with the restore part?  I'm now full of doubt and worry that my real
> > systems are not really backed up.
> >
> > I really wished this worked as easy as falling out of a boat and hitting
> water.
> >
> > Kevin
> >
>  I have used dump/restore to move systems onto other drives, sometimes even
> through an ssh connection. The only thing you have to remember is to:
>  chmod 1777 /tmp

I finally got a good restore.  I meant to reply all to document my
solution, but hit reply to Anders only I guess.  I was booting off the
Live CD and had to soft link /tmp to a drive with some free space.
After that everything worked perfect.


More information about the freebsd-questions mailing list