Can't log in as root on new 7.0 install

Jesse Sheidlower jester at
Mon Apr 14 16:30:19 UTC 2008

On Mon, Apr 14, 2008 at 10:04:21AM -0500, Derek Ragona wrote:
> At 09:35 AM 4/14/2008, Jesse Sheidlower wrote:
> >I've recently installed FreeBSD 7.0 on a new server. I seem to
> >be unable to log in as root in any way, and I'm not sure why.
> >Furthermore I'm now physically separate from the machine, and
> >have been relying on a (non-computer-literate) colleague with
> >access to its console server to try and help.
> >
> >After the initial install I (am pretty sure I) was able to log
> >in as root over ssh. However, after a week when the machine
> >was inaccessible for other reasons, I cannot log in as root,
> >only as a normal user.
> >
> >I thought that I had perhaps mis-remembered the root password,
> >so I directed the colleague to log in in single user mode and
> >reset the root password; she was able to do this, and typed
> >"exit" to return the system to multi-user mode and herself at
> >a root prompt. However I was still not able to log in as root,
> >either over ssh, or by logging in as a normal user and then
> >typing "login root" (i.e. it wasn't just something preventing
> >root logins over ssh).
> >
> >I then asked the colleague to add me to the "wheel" group,
> >which she successfully did; I logged out and back in again,
> >determined that I was indeed in this group, and tried to "su -"
> >and got a "su: Sorry" message, with the colleague reporting
> >that a "BAD SU [user] to root on /dev/ttyp0" message had
> >appeared.
> >
> >I'm sort of at a loss for what to do or why this is happening,
> >and am quite eager to control my own machine....Suggestions
> >welcome.
> >
> >Thanks very much.
> >
> >Jesse Sheidlower
> I would have your helper log in as root and reboot the server.  This will 
> assure it is in multi-user.
> You should NOT be able to ssh in as root, unless you've opened up that 
> security hole which is not recommended.

My helper did successfully log in as root over the console,
and rebooted the server. However, all of my above problems are
still the case: I cannot log in as root over ssh (OK, you
addressed this), or by logging in as a regular user and doing
a "login root"; and I cannot su to root even though I'm in the
wheel group.

When this is up and running I won't allow root logins at all,
but my issue right now is that I'm not at the console and need
to actually install things on the machine (sudo, for
example...). So aside from being on the console, how _can_ I
get this access on the machine?

Thanks again.

Jesse Sheidlower

More information about the freebsd-questions mailing list