Can't log in as root on new 7.0 install

Jesse Sheidlower jester at
Mon Apr 14 14:51:38 UTC 2008

I've recently installed FreeBSD 7.0 on a new server. I seem to
be unable to log in as root in any way, and I'm not sure why.
Furthermore I'm now physically separate from the machine, and
have been relying on a (non-computer-literate) colleague with
access to its console server to try and help.

After the initial install I (am pretty sure I) was able to log
in as root over ssh. However, after a week when the machine
was inaccessible for other reasons, I cannot log in as root,
only as a normal user.

I thought that I had perhaps mis-remembered the root password,
so I directed the colleague to log in in single user mode and
reset the root password; she was able to do this, and typed
"exit" to return the system to multi-user mode and herself at
a root prompt. However I was still not able to log in as root,
either over ssh, or by logging in as a normal user and then
typing "login root" (i.e. it wasn't just something preventing
root logins over ssh).

I then asked the colleague to add me to the "wheel" group,
which she successfully did; I logged out and back in again,
determined that I was indeed in this group, and tried to "su -" 
and got a "su: Sorry" message, with the colleague reporting
that a "BAD SU [user] to root on /dev/ttyp0" message had

I'm sort of at a loss for what to do or why this is happening,
and am quite eager to control my own machine....Suggestions

Thanks very much.

Jesse Sheidlower

More information about the freebsd-questions mailing list