Slow performance as root over SSH?

Edward Ruggeri smallhand at
Mon Apr 14 13:23:16 UTC 2008

Hi all,

(This may actually be a question for the dtach people).

I've recently been using dtach (basically the detach function of
screen) over SSH to instruct my freeBSD machine to perform long tasks
even after I disconnect from it.  It's worked great: I run SSH and
connect to my box, execute dtach to create a new session in which to
execute a program, hit ctr-\ to detach the session from the terminal,
and then I can close the SSH tunnel.

Recently, I figured to do this with portupgrade.  Now, I don't allow
root login, so I log in as a user in the wheel group and use su.  Now,
as root, I run: dtach -A portupgrade -a.  It starts working, but
extremely slowly.  For instance, "portsnap fetch update" takes several
minutes, whereas it normally is blazing fast when performed locally.
I can still detach, exit root, and close the SSH tunnel.  I suppose
this is probably a dtach performance issue?

If anyone has any thoughts, I'd definitely appreciate them.  Thanks!


-- Ned Ruggeri

More information about the freebsd-questions mailing list