Reading a Video CD from a DVD drive on 7.0

Nikolaj Thygesen mailinglist at
Sun Apr 13 09:50:02 UTC 2008

Joshua Isom wrote:
> After some further testing, a vcd in the dvd drive will have the same 
> problem during booting the kernel(before init). After killing the 
> system and rebooting without the disc, trying to play the disc causes 
> messages like this repeatedly. I tried running "cdcontrol -f /dev/acd1 
> eject" and it hung. I tried "atacontrol reinit ata3" and "atacontrol 
> detach ata3" and those hung as well. It's an sata dvd-rw drive over 
> atapi. Here's the error being reported by the kernel.
> acd1: TIMEOUT - READ_BIG retrying (1 retry left)
> acd1: TIMEOUT - READ_BIG retrying (0 retries left)
> acd1: FAILURE - READ_BIG timed out
> Mplayer just triggers the problem. I imagine if I ran amd I'd have the 
> same type of problem, or any program that tried to read from acd1. 
> Other than locking up tty's and not being able to shut down, the 
> system's still usable, aside from the disc inserted during boot of 
> course.
I get the exact same symptoms when booting with an audio cd in the 
drive. I haven't done too much about it as I rarely stuff such things in 
my box, but the cd/dvd part of fbsd7 still appears somewhat flakey. I 
see the "INQUIRY ILLEGAL REQUEST" below on several boxes. On this 
particular machine "atapicd" is commented out in its i386-based custom 
kernel config, but it makes no difference as far as this warning/error 
is concerned.

FreeBSD 7.0-RELEASE #4: Sun Mar 9 21:39:39 CET 2008
nikolaj at
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (2405.47-MHz 686-class CPU)
unknown: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
cd0 at ata4 bus 0 target 1 lun 0
cd0: <ATAPI DVD D DH16D2P HP57> Removable CD-ROM SCSI-0 device
cd0: 3.300MB/s transfers
cd0: cd present [2070890 x 2048 byte records]

br - N :o)

More information about the freebsd-questions mailing list