Reading a Video CD from a DVD drive on 7.0

Roland Smith rsmith at
Sat Apr 12 21:47:30 UTC 2008

On Sat, Apr 12, 2008 at 01:32:22AM -0500, Joshua Isom wrote:
> I recently made the upgrade to 7.0, and my girlfriend had some video cd's 
> she wanted help with(end result is putting two pal vcd's on one ntsc dvd).  
> I had a couple she'd given me before that were actually dvd's so I first 
> put the new ones in my dvd drive and tried using mplayer on them, but it 
> locks up with the read big timeout thing that I'm sure almost anyone who's 
> messed with dvd's has seen.

I haven't. DVD's work fine here with mplayer on amd64.

>  Under 6.3, that error would do the three 
> tries, and then another three, and quit.  I didn't not test under 6.3 using 
> an actual vcd so I'm not sure if that's specific to the issue or not.  But 
> under 7.0, it'd just keep retrying forever.  Since it was locked in device, 
> I couldn't kill it, I couldn't eject the disc, and had to forcibly reboot 
> the system.  Now, the operating system still worked, but the drive was 
> locked, and the kernel could not shut down.  I doubt this is expected or 
> tolerated behavior but given that it involves video cd's in a dvd drive 
> trying to be accessed as a dvd, I'm not sure it's been seen very often at 
> all.  Was behavior changed from 6 to 7, or was this just an untested case?  
> Does anyone know how best to deal with processes locked in "device"?

When trying to play a vcd in mplayer I just get a CDRIOCSETBLOCKSIZE

There are tools in ports to rip a VCD. See multimedia/vcdimager.

For wayward devices to can try using cdcontrol(1) or atacontrol(8).

[plain text _non-HTML_ PGP/GnuPG encrypted/signed email much appreciated]
pgp: 1A2B 477F 9970 BA3C 2914  B7CE 1277 EFB0 C321 A725 (KeyID: C321A725)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list