Apache22 Port Install Problem

Tim DeBoer tdeboer at gmail.com
Tue Apr 8 05:38:09 UTC 2008

I wasn't sure if I should post here or on the apache list, but since it's an
issue with the port version, rather than the tarball, hopefully this is the
right place.

The install goes fine, no obvious errors anyway, when I do apachectl
configtest, I get
# apachectl configtest
Syntax error on line 117 of /usr/local/etc/apache22/httpd.conf:
Invalid command 'Order', perhaps misspelled or defined by a module not
included in the server configuration

This is the related section in httpd.conf that it's complaining about:
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
# First, we configure the "default" to be a very restrictive set of
# features.
<Directory />
    AllowOverride None
    Order deny,allow
    Deny from all

I've tried re-compiling without any extra options at all, and I've tried it
with auth_basic enabled.
I made sure to use the "fresh" httpd.conf, each time but it made no
I'm really not sure how to proceed here.
Could someone point me in the right direction, please?

Thanks  :)

Tim DeBoer
The other day, I dropped a piece of bread and it fell butter side up.
I was convinced that I'd buttered the wrong side of the bread.

More information about the freebsd-questions mailing list