Tinydns configuration... works, but no reverse dns

John Almberg jalmberg at identry.com
Fri Apr 4 20:40:06 UTC 2008


I am using tinydns on my FreeBSD server. Normal DNS lookups work  
fine, but I can't get reverse DNS to work.

My colocation provider says they have delegated DNS to my name  
servers. If there is a way to independently verify this, I don't know  
how to do it, so I am taking their word for it.

My data file looks like this:

# DNS
.identry.com:66.111.0.195:ns0.identry.com
.identry.com:66.111.0.252:ns1.identry.com
.0.111.66.in-adr.arpa::ns0.identry.com:259200
.0.111.66.in-adr.arpa::ns1.identry.com:259200
#
# Server Addresses
#
=on.identry.com:66.111.0.194:3600
=www.identry.com:66.111.0.206:3600
+identry.com:66.111.0.206
@identry.com::mx1.identry.com.:10:3600
=mx1.identry.com:66.111.0.196

When I run tinydns-get on the mx record, I get this:

[root at on /usr/local/etc/tinydns/root]# tinydns-get a mx1.identry.com
1 mx1.identry.com:
149 bytes, 1+1+2+4 records, response, authoritative, noerror
query: 1 mx1.identry.com
answer: mx1.identry.com 86400 A 66.111.0.196
authority: identry.com 259200 NS ns0.identry.com
authority: identry.com 259200 NS ns1.identry.com
additional: ns0.identry.com 259200 A 66.111.0.195
additional: ns1.identry.com 259200 A 66.111.0.252

However, when I try to do a reverse look up, I get nada:

[root at on /usr/local/etc/tinydns/root]# tinydns-get ptr  
196.0.111.66.in-addr.arpa
12 196.0.111.66.in-addr.arpa:

This set up worked at my previous colocation provider, so I suspect  
there is something different about they way they are delegating, but  
I'm far from a DNS expert. Any advice, much appreciated.

Thanks: John





More information about the freebsd-questions mailing list