[unsure] Re: Problem starting X as user

Frank Wißmann frank.wissmann41 at web.de
Fri Apr 4 13:22:12 UTC 2008

herbert langhans wrote:
> Also check if you have the /etc/x11/xorg.conf -- root 644. Dont keep another xorg.conf in the /home/user directory so its using the one from /etc/x11 for sure. 
> Dont have 
> ~/.Xresources and
> ~/.Xmodmap 
> in the home directory. 

I must admit I have some xmodmap-commands in my .xinitrc. They worked 
fine in my 7.0-Beta1 installation. I now have upgraded to 7.0. X.org is 
7.3_1. I copied my ~/frank from one computer to another via NFS. May it 
be there went something wrong? (See below)
> Check .xinitrc if it is in /root. If it is there and it works copy it over to the /home/user, care for permissions or make it 777.

I have only one in ~/frank.

> Watch for /usr/local/lib/X11/xinit -- it will use this when you have no .xinitrc in the /home/user or permission is set wrong!

The file /usr/local/lib/X11/xinit/xinitrc is set to r--r--r--. It seems 
to me this is somehow wrong. Should I change it, and to which value?

> Such troubles I solve best when I look over it the next day. Usually I find it in two minutes then and wonder how I can have not seen such an obvious mistake.. 
> Cheers
> herbs
> On Thu, 03 Apr 2008 22:38:04 +0200
> Frank Wißmann <frank.wissmann41 at web.de> wrote:
>> herbert langhans wrote:
>>> Frank,
>>> can you start twm when you log in as a user. It smells like some permission issue from xfce. You could backup the xfce files with the actual permissions and then set them all to 777 and try to start it.
>>> Just an idea
>>> herbs
>>> On Thu, 03 Apr 2008 21:03:40 +0200
>>> Frank Wißmann <frank.wissmann41 at web.de> wrote:
>>>> Hi all!
>>>> Hope there's somebody out there who can help me with the following problem:
>>>> When I type "startx" as root all is coming up as expected, the X-Server 
>>>> and twm as WM. When I stop it, log in as a normal user and do the same 
>>>> there is only a grey screen with a mouse-cursor coming up and doing 
>>>> nothing until I kill the X-Server with Ctrl-Alt-Backspace. On the 
>>>> original screen from which I tried to start is shown the following error 
>>>> message:
>>>> AUDIT: Thu Apr 3 20:34:48 2008 836 X: client 1 rejected from localhost 
>>>> (uid 1001)
>>>> Auth name: XDM-AUTHORIZATION-1 ID: -1
>>>> Xlib: connection to "0:0" refused by server
>>>> Xlib: Protocol not supported by server
>>>> .xinitrc and .xsession both have the same contens "exec startxfce4" and 
>>>> the permissions "rwxr-xr-x".
>>>> Any thoughts please?
>>>> TIA Frank
>>>> _______________________________________________
>>>> freebsd-questions at freebsd.org mailing list
>>>> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
>>>> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"
>> If I comment out the "exec startxfce4" in both files the effect is the 
>> same: No WM starts, just the X-Server. The interesting effect is that 
>> the output on the regular user's terminal is the same as above written. 
>> So it seems it has nothing to do with the WM I want to start.
>> Frank

More information about the freebsd-questions mailing list