Webalizer compiles and installs fine in 6.1, goes splat in 6.2.

Lou Katz lou at metron.com
Thu Apr 3 16:37:03 UTC 2008

On Thu, Apr 03, 2008 at 12:11:52PM +0200, Mel wrote:
> On Thursday 03 April 2008 01:21:38 Lou Katz wrote:
> > In /usr/ports/webalizer (6.2)
> >
> > # make


> > -DHAVE_ICONV_H -DHAVE_ICONV_T_DEF -c gdft.c gdft.c:1403:35:
> > fontconfig/fontconfig.h: No such file or directory gdft.c:1466: error:
> Install x11-fonts/fontconfig or set WITHOUT_X11 cause you don't need XPM 
> support in GD anyway.
> And be sure to read:
> less -p20070519 /usr/ports/UPDATING
> -- 
> Mel

Thank you! Problem solved.

The 'funny thing' was:
a. This system is not an upgrade. It was a fresh install of 6.2.
b. When I did the initial make on webalizer, I foolishly checked the X11 boxes in
   the config screen.
c. However, the make mechanism apparently didn't properly pick up the dependency
   like it usually does.
d. When I got the errors, I tried to re-do the config, and just could not find any
   way at all to unring that bell. Make config did not work, as config was not
   a target. I even make a clean, empty ports tree and tried to make webalizer
   there hoping for another shot at the config screen, but it never appeared,
   and I got the same error. This leads to the question of where in the maze
   of twisty little passageways, all the same, did the make mechanism
   hide the X11 requirement????


Problem with today's modular software: they start with the modules
     and never get to the software part.

More information about the freebsd-questions mailing list