i810 driver problem

Predrag Punosevac punosevac at math.arizona.edu
Mon Oct 29 11:55:14 PDT 2007

Kevin Kinsey wrote:
> Predrag Punosevac wrote:
>> I was wondering if anybody encountered any problems with i810 video 
>> driver on 7.0Beta15 current.
>> Namely I did yesterday a fresh installation of an older Pentium III 
>> machine and was unable to get X going.
>> I got Xorg as pkg_add -r by the way and the rest of the system was 
>> installed from ISO image.
>> Yes, I did have
>> Section "ServerFlags"
>>          Option "IgnoreAbi" "on"
>> EndSection
>> I looked carefully xorg.conf.new and the listed video driver was 
>> i810. I did not manually compile that driver as I thought that was 
>> included into XOrg( at least on two other new computers I use i810 
>> driver and it was included into XOrg).
>> I tried though to load it manually into kernel by editing load.conf 
>> file. Sorry I am not enclosing  log file as  I wiped
>> installation. It was very late last night and I thought it will take 
>> me half an hour to get things working. I end up spending
>> 3 hours.
> Stupid question (especially since I dunno much about 7.0 yet),
> but you did have agp_load="YES" in loader.conf, and /dev/agpgart
> was created successfully?
> Note that I suppose it's possible this isn't necessary in 7.x,
> but it has been in the other branches for a Long Time Now(tm).
Yes I did have agp_load="YES". I have done some additional testing last 
night on that machine. First of all I tried OpenBSD 4.1 and I could 
start x even without xorg.conf file which is usually true in OpenBSD but 
the XOrg version is 6.9.
Then I did fresh installation of 7.0 and and did pkg_add -r Xorg.
I was monkeying around with the xorg.conf.new file and I was able to get 
going X -config   /root/xorg.conf.new. However when
I cp  /root/xorg.conf.new /etc/X11/xorg.conf.new and startx the X would 
start without clients and then would crush within a second. I could just 
see various colors  all over the place.

Then I tried to use xorgconfig  utility and created  xorg.conf  file  
with  very  conservative options ( I decreased the number of colors)
This time when I started x everything was fine for about 3 seconds and 
then crash again and colors all over the place. (kernel is also frozen)
I think I am getting somewhere but I need to play with this thing 
longer. For some reason when I xorgcfg -textmode I would get reply that
the command is not recognized. I will check this again.

I will try couple other things. I will also try to install 6.2 stable 
and see if I can get Xorg going.

This is an old DeLL dimension computer and the monitor I was using is 
Sony trinitron 15in. I will try with my 17in DeLL monitor to see if that 
makes any difference.

>> Then I tried PC-BSD 1.4 which is 6.2 stable from July and everything 
>> went without a hitch.
>> I checked xorg.conf and I saw that the listed driver is 
>> Xf86-video-intel-2.1.1
>> Should I try to install Xf86-video-intel-2.1.1 and then just try to 
>> hand configure xorg.conf file.
>> I did notice some discussion yesterday about i810 but I thought it 
>> was relevant just for upgrading not for the new installation.
>> Any input or suggestion will be appreciated.
>> Predrag Punosevac
> Hoping it helps,
> Kevin Kinsey

More information about the freebsd-questions mailing list