during gnome upgrade the upgrading of epiphany fails

Dino Vliet dino_vliet at yahoo.com
Sun Oct 28 07:47:23 PDT 2007

                Hi freebsd folks,
 I wanted to upgrade my ports but epiphany gave the folowwing errror:
 Using config source xml:merged:/usr/local/etc/gconf/gconf.xml.defaults for schema installation 
 Using $(sysconfdir)/gconf/schemas as install directory for schema files 
 checking for gconftool-2... /usr/local/bin/gconftool-2 
 checking for mkdtemp... yes 
 checking for which engine to use... mozilla 
 checking for gawk... (cached) gawk 
 checking which gecko to use... firefox 
 checking for compiler -fshort-wchar option... yes 
 checking whether to enable C++ RTTI... no 
 checking whether we have a gtk 2 gecko build... yes 
 checking whether we have a gecko debug build... no 
 checking for gecko version... 1.8.1 
 checking for GECKO... yes 
 checking whether we can compile and run XPCOM programs... no 
 configure: error: Cannot compile and run XPCOM programs 
 See `config.log' for more details. 
 ===>  Script "configure" failed unexpectedly. 
 Please run the gnomelogalyzer, available from 
 "http://www.freebsd.org/gnome/gnomelogalyzer.sh", which will diagnose the 
 problem and suggest a solution. If - and only if - the gnomelogalyzer cannot 
 solve the problem, report the build failure to the FreeBSD GNOME team at 
 gnome at FreeBSD.org, and attach (a) 
 "/usr/ports/www/epiphany/work/epiphany-2.20.1/config.log", (b) the output of 
 the failed make command, and (c) the gnomelogalyzer output. Also, it might 
 be a good idea to provide an overview of all packages installed on your system 
 (i.e. an `ls /var/db/pkg`). Put your attachment up on any website, 
 copy-and-paste into http://freebsd-gnome.pastebin.com, or use send-pr(1) with 
 the attachment. Try to avoid sending any attachments to the mailing list 
 (gnome at FreeBSD.org), because attachments sent to FreeBSD mailing lists are 
 usually discarded by the mailing list software. 
 *** Error code 1 
 Stop in /usr/ports/www/epiphany. 
 ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.36048.0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=epiphany-2.18.3 UPGRADE_PORT_VER=2.18.3 make WITH_FAM_SYSTEM=fam 
 ** Fix the problem and try again. 
 ** Listing the failed packages (*:skipped / !:failed) 
         ! www/epiphany (epiphany-2.18.3)        (configure error) 
 --->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed 
 The actions I exectued to solve tis were:
 I tried to use gnomelogalyzer but it gave me the following output:
  sh /home/rgilaard/Desktop/gnomelogalyzer.sh  
 Generating build log. Please wait... done. 
 The cause of your build failure is not known to gnomelogalyzer.sh.  Before 
 e-mailing the build log to the FreeBSD GNOME team at freebsd-gnome at FreeBSD.org, 
   * If you are generating your own logfile, make sure to generate it with 
     something similar to: 
           "make 2>&1 | tee /path/to/logfile" (sh/bash/ksh/zsh) or 
           "make |& tee /path/to/logfile" (csh/tcsh) 
         * Make sure your cvsup(1) configuration file specifies the 'ports-all' 
         * Run cvsup(1) and attempt the build again 
         * Check /usr/ports/UPDATING for information pertinent to your build 
         * 99% of the commonly reported build failures can be solved by 
           running "portupgrade -a" 
         * Read the FAQs at http://www.FreeBSD.org/gnome/ 
         * Search the archives of freebsd-gnome at FreeBSD.org.  Archives can be 
           searched at http://www.freebsd.org/gnome/index.html#search 
 If you have not performed each of the above suggestions, don't bother asking 
 for help.  The chances are good that you'll simply be told to perform one of 
 the aforementioned steps. 
 The "/usr/ports/www/epiphany/work/epiphany-2.20.1/config.log" file is in the attachement and I posted it on the site http://freebsd-gnome.pastebin.com/m289db501

 How can I proceed?

My system is a amd64 running freebsd 6.2.

 Dino Vliet
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: epip_config.log
Type: application/octet-stream
Size: 57969 bytes
Desc: 2561323617-epip_config.log
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20071028/d6c7b5c9/epip_config.obj

More information about the freebsd-questions mailing list