phpinfo(); not working

Tipper tip at
Fri Oct 26 20:37:26 PDT 2007

I have FreeBSD-6.2 and I'm having trouble setting up apache, mysql and 
php for my business. I can't get  phpinfo(); to display. If I run php 
-i, I get several pages of information which means php is working.  Out 
of three different types of php, php-html isn't operating.  My browser 
is where I do 100 percent of my work. Both PHP CLI and PHP CGI seem to 
work. If it can't display phpinfo();, it won't run my custom designed 
php software.  I did successfully install it a few years ago with 
FreeBSD-4.8 and older versions of PHP.  The install disk for FreeBSD-4.8 
became defective and I had to re-order.  They only had FreeBSD-6.2. This 
where the trouble starts.

The 'install file' from says:

   In case of setting up the server and PHP on your own, you have two
   choices for the method of connecting PHP to the server. For many
   servers PHP has a direct module interface (also called SAPI). These
   servers include Apache, Microsoft Internet Information Server, Netscape
   and iPlanet servers. Many other servers have support for ISAPI, the
   Microsoft module interface (OmniHTTPd for example).

Reading the above, I think my 'sapi module' wasn't installed.
Using the 'find program', I ran sapi, SAPI. isapi, nsapi, ISAPI and 
NSAPI.  I received a responce for isapi,
sapi and nsapi. 'sapi' was located at '/port/php-4.4/sapi'.  Both isapi 
and nsapi are located under sapi. But 'sapi' was just a directory,  I 
was expecting to find some sort of program.

For apache, mysql and php, I have all the files. When installing php, it 
automatically updates httpd.conf.  I always double check to make sure.  
/usr/local/libexec/apache has about 35 modules including ''.  
The main php file is located in /usr/local/bin/php.  Using telnet, it 
confirms php is working.

I did several re-installs of FreeBSD and different combinations of 
apache, mysql and php.  If I use FreeBSDs apache-1.3 and mysql-5.1 and 
php4 from it will work, but only once.  I tried to improve 
it, but couldn't.  How many times can I reboot to make one order?  This 
is version I'm working on.

  - does the 'sapi module' have a different name, so I can find it with 
the 'find program'?
  - if the 'sapi module' is missing, how do I replace it?

uname -a: Freebsd localhost 6.2-RELEASE FreeBSD 6.2-RELEASE  #0: Friday 
Ost 5 15:08:51 UTC root@:/usr/src/sys/compile/HAP i386

Thanks in advance,

More information about the freebsd-questions mailing list