Qemu: mouse doesn't work

Michael Gerhards HM-Gerhards at web.de
Fri Oct 26 09:30:10 PDT 2007

I installed Qemu 0.9.0 with kqemu 1.3.0.p11 on FreeBSD 6.2 in order to
get Kanotix running under FreeBSD. 
Kanotix boots well under qemu (I use the ISO-image) - but after the KDE
desktop appears, my mouse doesn't work properly any more.  When I move
my mouse, the cursor sometimes moves a bit in the same direction,
sometimes it jumps to the other side of the Kanotix desktop - and every
few seconds the moving cursor disappears. But I can see some "old"
cursors that did not disappear as I moved my mouse. So I cannot work
with Kanotix under qemu at all because I don't really see where the
cursor is when I move my mouse. 
I already tried using "-usbdevice tablet", I tried setting
SDL_VIDEO_X11_DGAMOUSE=0 and I even tried to use Qemu via vnc - nothing
solves my problem. 
Any ideas how I could get Kanotix working under Qemu? What might cause
the trouble in my case? Is this problem caused by Qemu or is it caused
by FreeBSD?

Many thanks in advance, 

More information about the freebsd-questions mailing list