user ppp and PPPoE bridging

freebsd at freebsd at
Tue Oct 23 23:30:51 PDT 2007

To answer my own question:

I had the mux type set wrong -- VC-based instead of LLC-based.
While the line comes up, the session is never opened because of the mux

moving right along now...


> The freebsd box is connected directly via ed1 to the dsl modem;
> a crossover cable is used; the packets are clearly reaching the modem,
> as it records them as received.
> I've simplified ppp.conf to the following, essentially the ppp.conf.sample:
> default:
>  set log all -timer
> blackfoot:
>  set device PPPoE:ed1
>  enable lqr echo
>  set cd 5
>  set redial 0 0
>  set dial
>  set login
>  set authname xxxxxxxx
>  set authkey yyyyyyyy
>  add! default HISADDR
> #ifconfig ed1
>         inet6 fe80::220:18ff:fe72:8b72%ed1 prefixlen 64 scopeid 0x3
>         ether 00:20:18:72:8b:72
> #tcpdump -efntl -i ed1
> tcpdump: WARNING: ed1: no IPv4 address assigned
> tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
> listening on ed1, link-type EN10MB (Ethernet), capture size 96 bytes
> 00:20:18:72:8b:72 > ff:ff:ff:ff:ff:ff, ethertype PPPoE D (0x8863), 
> length 32: PPPoE PADI [Host-Uniq 0x402DA4C1] [Service-Name]
> 00:20:18:72:8b:72 > ff:ff:ff:ff:ff:ff, ethertype PPPoE D (0x8863), 
> length 32: PPPoE PADI [Host-Uniq 0x402DA4C1] [Service-Name]
> It appears that no PADO reply is being received by the modem;
> the modem shows two packets being transmitted, but non being received.
> Since the line is marked as up by the modem,
> and since the line comes up properly when the modem is operating in
> full PPPoE mode, I'm puzzled as to what kind of mismatch could be
> preventing the ISP end from responding.
> This is a zyxel 642r modem; I can't try my other modem, a cisco 678,
> because it doesn't support a vci > 63.
> The modem is set to use VC-based multiplexing, vpi=0, vci=100
> These are the parameters used for PPPoE, and I presume are still
> required as part of the ATM layer when bridging.
> I am assuming there should be no need for my ISP to be notified that I
> am trying to use bridging in the modem, since it should be transparent
> on their end.  They claim not to support bridging, but I don't see how
> they can say that, other than that they don't want to deal with the
> support issues.  Is this a reasonable assumption?
> Nikos Vassiliadis wrote:
>> On Tuesday 23 October 2007 05:31:45 freebsd at wrote:
>>> I'm attempting to change a DSL link from using PPPoE in the DSL modem
>>> to doing PPPoE on 6.1, with the modem in bridging mode.
>>> I've put the DSL modem in bridging mode, and it brings up the link
>>> properly -- or at least it reports it as up (DSL led steady; modem
>>> status report shows it as up, rfc 1483.
>>> Using user ppp, when I attempt to establish the PPPoE connection, I
>>> never get very far -- ppp dies when it tries to acquire carrier.  I
>>> don't understand this, as there isn't a carrier signal to acquire on
>>> an ethernet.  
>> There is carrier on ethernet. Ethernet belongs to the CSMA/DA model
>> where CS means carrier sense.
>>> I tried disabling cd in ppp.conf but as noted in the doc, it's 
>>> required for a PPPoE connection and is forced on.
>>> Also, how do I know know which interface it is attempting to connect to?
>>> The debug log shows it found five interfaces, but doesn't indicate which
>>> one it is trying to connect to.
>> It tries to use ed1 for PPPoE(set device PPPoE:ed1)
>> Can you use the minimal configuration labelled pppoe
>> from /usr/share/examples/ppp/ppp.conf.sample?
>> The only things you have to change are:
>> The ethernet interface it will try PPPoE.
>> username and password.
>> Is your ed1 connected to the modem directly?
>> Or it goes through a switch? Can you try connecting
>> your ed1 directly on your DSL modem's ethernet port?
>> You might need a crossover cable to do this(
>> or not since these days many ethernet ports do
>> this automatically.
>> Please post also ifconfig and run tcpdump on ed1
>> during try.
> ...
>> I dont'see anything wrong, but I may be wrong. The small
>> sample configuration always worked for me. Why don't you
>> use it as a starting point?

More information about the freebsd-questions mailing list