user ppp and PPPoE bridging

Nikos Vassiliadis nvass at
Tue Oct 23 02:02:33 PDT 2007

On Tuesday 23 October 2007 05:31:45 freebsd at wrote:
> I'm attempting to change a DSL link from using PPPoE in the DSL modem
> to doing PPPoE on 6.1, with the modem in bridging mode.
> I've put the DSL modem in bridging mode, and it brings up the link
> properly -- or at least it reports it as up (DSL led steady; modem
> status report shows it as up, rfc 1483.
> Using user ppp, when I attempt to establish the PPPoE connection, I
> never get very far -- ppp dies when it tries to acquire carrier.  I
> don't understand this, as there isn't a carrier signal to acquire on
> an ethernet.  

There is carrier on ethernet. Ethernet belongs to the CSMA/DA model
where CS means carrier sense.

> I tried disabling cd in ppp.conf but as noted in the doc, 
> it's required for a PPPoE connection and is forced on.
> Also, how do I know know which interface it is attempting to connect to?
> The debug log shows it found five interfaces, but doesn't indicate which
> one it is trying to connect to.

It tries to use ed1 for PPPoE(set device PPPoE:ed1)
Can you use the minimal configuration labelled pppoe
from /usr/share/examples/ppp/ppp.conf.sample?
The only things you have to change are:
The ethernet interface it will try PPPoE.
username and password.

Is your ed1 connected to the modem directly?
Or it goes through a switch? Can you try connecting
your ed1 directly on your DSL modem's ethernet port?
You might need a crossover cable to do this(
or not since these days many ethernet ports do
this automatically.

Please post also ifconfig and run tcpdump on ed1
during try.

> ============  ppp.conf:  ===========
> default:
>   set log all
>   set log -timer
>   ident user-ppp VERSION (built COMPILATIONDATE)
>   set redial 15 0
>   set reconnect 15 10000
> isp:
>   set device PPPoE:ed1
>   disable acfcomp protocomp
>   deny acfcomp
>   set mtu max 1492
>   set mru max 1492
>   enable mssfixup
>   set speed sync
>   enable lqr
>   set lqrperiod 5
>   set ctsrts off
>   disable ipv6cp
>   set dial
>   set login
>   set timeout 0
>   set authname xxxxxx
>   set authkey yyyyyy
>   add! default HISADDR

I dont'see anything wrong, but I may be wrong. The small
sample configuration always worked for me. Why don't you
use it as a starting point?


More information about the freebsd-questions mailing list