OpenLDAP 2.3/pam_ldap/nss_ldap: not working in FreeBSD 7.0-PRE!

O. Hartmann ohartman at
Mon Oct 22 06:19:20 PDT 2007

Per olof Ljungmark wrote:
> O. Hartmann wrote:
>> For weeks now I tried to get an OpenLDAP-server on a local FreeBSD 
>> 7.0-PRE box running, but with no success. Within the last 8 weeks I 
>> tried nearly EVERY tutorial and there explained setups, but whenever I 
>> try to authenticate or find an ID for an existing user in the DIT, I 
>> receive either errors that the client (pam/nss, ssh, id etc.) can not 
>> connect to the slapd running on the same machine.
> <snip>
> We have this config running on 7 since months. I suggest you provide the 
> list with more information + log excerpts, then someone might help you out.
> --per

Well, great, I appreciate your help and by teh way, you're the first one 
  telling he's running FBSD 7 AND OpenLDAP/nss_ldap/pam_ldap.

OpenLDAP is running well on the server, I can access the DIT via some 
tools like LUMA and the OpenLDAP clients from remote machines.

A major problem seems to be the pam_ldap/nss_ldap configuration. Can you 
please tell me how you edited /etc/pam.d/ files and /etc/nsswitch.conf 
properly? At this very moment it seems that I shot myself into the foot 
- the box running the LDAP service does not start OpenLDAP service slapd 
after rebooting, the console is stuck at the message shown when 
'additional ABI's' get started. So, I'm sorry having no logs handy at 
this very moment, I will offer them as soon as possible included with my 
config files, if this will not bother you.

Thanks in advance,

Planetology and Remote Sensing
FU Berlin

More information about the freebsd-questions mailing list