New data. (Was: Re: xorg driver bug)

Gary Kline kline at
Mon Oct 15 14:17:16 PDT 2007

On Tue, Oct 16, 2007 at 12:17:53AM +0330, Bahman M. wrote:
> On 2007-10-15 Gary Kline wrote:
> > On Sun, Oct 14, 2007 at 10:37:10PM -0700, Gary Kline wrote:
> > > 	Guys,
> > > 
> > > 	Has anybody with any Dell run into this before?  I just got
> > > a new Matrox with 32M of video ram.  Run with the "mga" driver, X
> > > comes up extremely dark.  If I change the driver to the "vesa" X
> > > comes up with normal brightness but the resolution is terrible.  At
> > > 	most 640x480.  tHis could be a hardware bug;I'm hoping it is
> > > 	just not having selected the right driver.  
> > > 
> > > 	Anybody know what to try next?
> > > 
> > 
> > 	Update, and no-joy: i've added Modes lines, tried different
> > flags. Still, using the "mga" drivr gives a dark screen; only the
> > "vesa" works. none of the xorg config toools work.  The Matroc
> > Millennium G450 is brand new, so doubt it's the card.  The previous
> > card had the same problem--way to dark--soI got this new card.
> > 
> Some years ago, I had some similar problem with a Vistac monitor using
> nVidia (on Linux).  I found that it was the monitor not doing well in
> some resolutions or colour depths.  Changing the monitor solved the
> problem.
> I'd suggest you try with another monitor and see if it works.

	It *could* be my CRT but it works on my 3 other KVM'd platforms 
	flawlessly.  Besides, the reason I bought the new G450 was
	because the  exact same thing was happening with my other v-card.

	I tried "mga" and gathered the following data from the failure
	dump.   [[X did work, but there was  this huge, dark band a
	couple inches from the top (where the display was much lightr)
	and after the drk middle band, the display was also light toward
	the bottom.

	Here is what I found after I did a shutdown now:

Requesting insufficient memory window!:  start 0xfd800000 to 0x7efffff size 0x2000000
(EE) Cannnot find empty range to map base to
(II)  Module "ramdac" already built-in
(EE)  [drm] drmOpen failed  
(EE) DRM(0) [dm]  DRMScreenInit failed  .  Disabling DRI

	Does this ring a bell among anybody who is familiar with xorg?
	My thinking now is that something is wrong with  the video on the 
	m'board; that both this new G50 and the last card were all right.

	Any thoughts?


> HTH,
> Bahman

  Gary Kline  kline at  Public Service Unix

More information about the freebsd-questions mailing list