1 TB data copy

John Nielsen john at jnielsen.net
Fri Oct 12 06:14:58 PDT 2007

Quoting Bill Moran <wmoran at potentialtech.com>:

> In response to "Monah Baki" <mbaki at whywire.net>:
>> Hi all,
>> We have a windows 2003 server and 1 freebsd 6.2 server. The 2003 server
>> supports USB 1 while the freebsd supports usb 2.
>> We went and purchased an external 1 TB usb 2 harddrive.
>> Our objective is to copy 700GB worth of data from the windows to the freebsd
>> server then take the external harddive to a remote client who runs windows
>> 2003 and then copy the data back to the windows server.
>> The throughput of copying the data from windows to the usb attached to it
>> was ridiculous, more than 12 hours to copy 60GB of data.
>> I tried copying a 1GB file from windows to the usb attached to the freebsd
>> and it took less than 5 minutes, but ofcourse when I tried to mount the
>> usb back to the windows box I could not see the 1GB file that I copied.
>> How can use the freebsd as the destination copy since it has a much better
>> throughput and at the same time have the windows box see the 600GB file
>> that was copied once I attach the usb harddrive to it.
> I expect the filesystem is the problem.  Windows doesn't understand UFS.
> FAT has been the traditional solution to this, since just about every OS
> understands FAT, but I don't believe FAT will support files as large
> as you're working with.
> I'm not completely up to speed with FreeBSD's NTFS support.  Last I looked
> at it, it was experimental and there were warnings everywhere.  I assume
> it's improved since then (~3 years ago) but can't say with authority.
> However, I think that's your only option.  Luckily, since you're just
> using the USB drive to move a file, and can keep it safe in another
> location until you're sure it transferred safely, this shouldn't be too
> risky.
> I would format the drive with the Windows machine and make it NTFS, then
> work with the FreeBSD mount options to get FreeBSD to mount it.  Have a
> look at mount_ntfs.

I agree with your approach but, mount_ntfs is still essentially 
read-only. Fortunately ntfs-3g has been ported (using FUSE), so the OP 
should be able to use that instead. See the sysutils/fusefs-ntfs port.


More information about the freebsd-questions mailing list