FTP & CRON Script

Derek Ragona derek at computinginnovations.com
Wed Oct 10 14:46:18 PDT 2007

At 04:31 PM 10/10/2007, White Hat wrote:
>This is driving me crazy. I have a small script that I
>run from CRON. It is run as a regular user and not as
>ROOT, although I have tried it both ways. It uploads
>SPAM to the 'knujon.com' site'.
>I have created a ~/.netrc file that looks like this:
>machine knujon.com
>         login user
>         password secret
>macdef  spam
>         put $1
>         quit
>Now, if I run the following command from the command
>prompt, the script works fine.
>echo \$ spam spam.zip | ftp -n
>The above should all be on one line, although it may
>be shown split into two right now.
>However, if this is put into a bash script, and run if
>from CRON, I receive a mail with this error message:
>'spam' macro not found.
>I have no idea what I am doing wrong.
>I have the $HOME, $SHELL and $PATH variables set in

try set -x and see what the output looks like.  I'd guess you are not 
escaping the $ right in your script.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
MailScanner thanks transtec Computers for their support.

More information about the freebsd-questions mailing list