help, make installworld fails!!!!!!

Dino Vliet dino_vliet at
Sun Oct 7 08:32:48 PDT 2007


I'm about to experience the first problem with FreeBSD after I've tried to upgrade my kernel to the latest sources because of the security advisories.  I have a custom kernel running FreeBSD version 6.2 on a amd64 system.

My procedure was:

step 1) change the src-supfile file to get the version of freebsd you want

step 2) Change file /usr/src/sys/amd64/conf/MYKERNEL to get the kernel options you want

step 3) cp /usr/src/sys/amd64/conf/MYKERNEL /root/kernels/MYKERNEL
 (make a backup of the kernel configuration in a seperate directory)

step 4) cvsup -g -L 2 src-supfile (check if MYKERNEL is still in
 /usr/src/sys/amd64/conf directory otherwise copy from /root/kernels

step 5) shutdown now and go into single user mode

step 6) look at step 11

step 7) cd /usr/src and make buildworld

step 8) make buildkernel KERNCONF=MYKERNEL

step 9) make installkernel KERNCONF=MYKERNEL

step 10) reboot into single user mode

step 11)     Then, when the system starts a /bin/sh shell instance,

    # adjkerntz -i
    # fsck -p
    # mount -u /
    # mount -a

step 12) cd /usr/src

step 13) mergemaster -p (pre buildworld mode, look into
 /usr/src/UPDATING to check if you have to do this before step 7!!)

step 14) make installworld

step 15) mergemaster -i

step 16) exit and reboot

However, at step 14 I ran out of luck as I got the following error:

mkdir -p /tmp/install.gurnx5I7
for prog in [ awk cap_mkdb cat chflags chmod chown  date echo egrep find grep install-info  ln lockf make mkdir mtree mv pwd_mkdb rm sed sh sysctl  test true uname wc zic; do  cp `which $prog` /tmp/install.gurnx5I7;  done
cd /usr/src; MAKEOBJDIRPREFIX=/usr/obj  MACHINE_ARCH=amd64  MACHINE=amd64  CPUTYPE=  GROFF_BIN_PATH=/usr/obj/usr/src/tmp/legacy/usr/bin  GROFF_FONT_PATH=/usr/obj/usr/src/tmp/legacy/usr/share/groff_font  GROFF_TMAC_PATH=/usr/obj/usr/src/tmp/legacy/usr/share/tmac  PATH=/usr/obj/usr/src/tmp/legacy/usr/sbin:/usr/obj/usr/src/tmp/legacy/usr/bin:/usr/obj/usr/src/tmp/legacy/usr/games:/usr/obj/usr/src/tmp/usr/sbin:/usr/obj/usr/src/tmp/usr/bin:/usr/obj/usr/src/tmp/usr/games:/tmp/install.gurnx5I7 make -f Makefile.inc1 reinstall
>>> Making hierarchy
cd /usr/src; make -f Makefile.inc1 hierarchy
cd /usr/src/etc;        make distrib-dirs
mtree -eU  -f /usr/src/etc/mtree/BSD.root.dist -p /
mtree -eU  -f /usr/src/etc/mtree/BSD.var.dist -p /var
mtree -eU  -f /usr/src/etc/mtree/BSD.usr.dist -p /usr
mtree -eU  -f /usr/src/etc/mtree/BSD.include.dist  -p /usr/include
mtree -deU  -f /usr/src/etc/mtree/BIND.chroot.dist  -p /var/named
mtree -deU  -f /usr/src/etc/mtree/BSD.sendmail.dist -p /
cd /; rm -f /sys; ln -s usr/src/sys sys
cd /usr/share/man/en.ISO8859-1; ln -sf ../man* .
cd /usr/share/man;  set - `grep "^[a-zA-Z]" /usr/src/etc/man.alias`;  while [ $# -gt 0 ] ;  do  rm -rf "$1";  ln -s "$2" "$1";  shift; shift;  done
cd /usr/share/openssl/man;  set - `grep "^[a-zA-Z]" /usr/src/etc/man.alias`;  while [ $# -gt 0 ] ;  do  rm -rf "$1";  ln -s "$2" "$1";  shift; shift;  done
cd /usr/share/openssl/man/en.ISO8859-1; ln -sf ../man* .
cd /usr/share/nls;  set - `grep "^[a-zA-Z]" /usr/src/etc/nls.alias`;  while [ $# -gt 0 ] ;  do  rm -rf "$1";  ln -s "$2" "$1";  shift; shift;  done

>>> Installing everything
cd /usr/src; make -f Makefile.inc1 install
===> share/info (install)
===> include (install)
creating osreldate.h from
touch: not found
*** Error code 127

Stop in /usr/src/include.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

So what do I have to do now? How do I proceed next?
Hope somebody can help me out,


Fussy? Opinionated? Impossible to please? Perfect.  Join Yahoo!'s user panel and lay it on us.

More information about the freebsd-questions mailing list