OpenSSL/PHP/Apache problem

Don O'Neil lists at
Sat Oct 6 13:47:29 PDT 2007

Any time I compile PHP 4.4.7 with --with-ssl my apache 1.3.39 server core
dumps on start up on my FreeBSD 6.1 dual core AMD X2 box (in 32 bit mode).
Anyone have a work around for this or suggestions where to look/try? I was
having a similar problem with Curl, but once I told curl where the OpenSSL
home dir was and re-built it that solved that problem. The location of my
openSSL is /usr/local, so it's in the 'default' location. I ran the core
through gdb, and that is what prompted me to isolate the problem to

Here's my build options/script for php:

./configure \
        --with-apxs \
        --with-gd \
        --with-gd-dir=/usr/local \
        --with-gettext \
        --with-jpeg-dir=/usr/local/lib \
        --with-mcrypt \
        --with-mhash \
        --with-mysql=/usr/local/mysql \
        --with-pear \
        --with-png-dir=/usr/local/lib \
        --with-xml \
        --with-zlib \
        --with-zlib-dir=/usr/local/lib \
        --with-zip \
        --enable-bcmath \
        --enable-calendar \
        --enable-ftp \
        --enable-magic-quotes \
        --enable-sockets \
        --enable-track-vars \
        --enable-mbstring \
        --with-curl \
        --with-curl-dir=/usr/local/lib \
        --with-imap=/usr/local/imap-2000e \
        --with-imap-ssl \
    	  --with-openssl \

More information about the freebsd-questions mailing list