portupgrade SOS

Kevin Kinsey kdk at daleco.biz
Thu Oct 4 18:48:13 PDT 2007

luizbcampos at gmail.com wrote:
>        Dear Sirs
>        After I had cvsuped FreeBSD-6.1-R amd64 I tried to portupgrade it but
> I got the following mssg:
> cd: can't cd to  /usr/ports/sysutils/portupgrade

Moved, see below.

> cd: can't cd to  /usr/ports/net/openldap22-client

Removed, outdated.  openldap23 is still available,
or at least was a month ago.

> cd: can't cd to  /usr/ports/x11/xorg-manpages

Orphaned in May with upgrade to xorg 7.2

> ---------->Upgrading 'gsfonts-8.11_2 to gsfonts-8.11_4' (print gsfonts)
> ---------->Building '/usr/ports/print/gsfonts'
> On FreeBSD before 6.2 ports system unfortunately can not set default X11BASE
> by itself so please help it a bit by setting X11BASE=$(LOCALBASE) in
> make.conf. On the other hand, if you do wish to use non-default X11BASE,
> please set variables USE_NONDEFAULT_X11BASE.
> ***Error code 1

Can you show the relevant line from your /etc/make.conf?

>>> Such message repeats to many other packages to be upgraded. I tried to
> add the said parameters on the message in  /etc/make.conf  but the error
> lingers on

Did you read /usr/ports/UPDATING?

Everything I see here is mentioned in that doc ;-)  Pay
special attention to the upgrade to xorg-7.2 --- Kris
wrote very explicit instructions for that.

I'd just force a reinstall of /usr/ports/ports-mgmt/portupgrade
and go from there ... after reading UPDATING.

Kevin Kinsey
What the hell, go ahead and put all your eggs in one basket.

More information about the freebsd-questions mailing list