Long msg: Unable to enable audio in FreeBSD 6.2 - Chipset VT8233A

Sai Vinob saivinob at yahoo.com
Mon Oct 1 10:19:15 PDT 2007

Hi all,
I'm not able to enable sound on my FreeBSD 6.2 box. I'm trying it here
in mailing lists after trying in

The error message when I click on the speaker icon is:
The volume control did not find any elements and/or devices to control.
This means either that you don'thave the right GStreamer plugins
installed, or that you don't have a sound card configured.

My motherboard is Asus K8V-VM Ultra with southbridge VT8233A. It uses a
realtek ALC660 codec.

Initially, 'kldstat' just showed:
Id Refs Address    Size     Name
 1   10 0xc0400000 6f6544   kernel
 2    1 0xc0af7000 59f20    acpi.ko
 3    1 0xc4364000 16000    linux.ko
 4    1 0xc43b9000 17000    ng_btsocket.ko
 5    1 0xc43d0000 a000     netgraph.ko
 6    1 0xc43de000 2000     ng_bluetooth.ko

and /dev/sndstat did not exist.

I then tried 'kldload snd_via8233' and I got this for 'cat
#cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices:

I tried 'kldload snd_driver', the generic case too. But no use.

Then I tried loading it as boottime module with
'snd_via8233_load="YES"' in the /boot/loader.conf file. The 'kldstat'
now shows,
Id Refs Address    Size     Name
 1   12 0xc0400000 6f6544   kernel
 2    1 0xc0af7000 6170     snd_via8233.ko
 3    2 0xc0afe000 22b88    sound.ko
 4    1 0xc0b21000 59f20    acpi.ko
 5    1 0xc4368000 16000    linux.ko
 6    1 0xc43c6000 17000    ng_btsocket.ko
 7    1 0xc43bb000 a000     netgraph.ko
 8    1 0xc43e1000 2000     ng_bluetooth.ko

But this did not solve the problem.

Looking at the error msg which talked about GStream plugins, I did
/usr/sysinstall and from ftp installed whatever GStreamer thing I could
find. But nothing helped. 

Could anyone guide me in activating audio in my box.

      Save all your chat conversations. Find them online at http://in.messenger.yahoo.com/webmessengerpromo.php

More information about the freebsd-questions mailing list