problem with dual disk/ dual boot installation

Joerg van den Hoff j.van_den_hoff at
Fri Nov 30 10:15:33 PST 2007

dear list,

today  I've  tried  a  very first installation of 6.2 on the
second  disk  of  an  i86  machine  which  runs  windows  xp
professional 2002 service pack 2 on disk one.

initially,  I  erroneously  did _not_ select installation of
the boot manager on the first disk (were  windows  resides),
but only on the second (the BSD one).

after  the  intallation  was  completed without any apparent
problems I noted my mistake (well, the machine  was  booting
windows  ...)  and tried to correct it first with sysinstall
doing excactly how the manual said (select first disk, leave
immediately  with  Q  and  procede etc.). this had no effect
(windows booting without any boot manager appearing....).

second I tried to use

bootinstall.exe boot.bin

from  disk  1.  this led first to a message from windows (in
german). approx.  translation:

"application  tries  to access the disk directly. this is not
supported. this can result in  incorrect  operation  of  the

after 'ignore'ing this message I got

"Error 128 reading boot record from disk 0."

in the dos shell.

I've  never  used  windows at all (rather MacOS X) up to now
(but want to keep windows functional on the machine).  so  I
don't  know  if  I  encounter  a  trivial windows permission
problem here or what else.

I tried to find the answer in the docs/faqs but to no avail.

therefore,  any help would be greatly appreciated. since I'm
not (yet) supscribed  to  the  list,  mail/cc  me  directly,

thanks in advance,


More information about the freebsd-questions mailing list