Amarok crashes X (since portupgrade)

John Murphy freebsd001 at
Thu Nov 29 20:31:21 PST 2007

On Thu, 29 Nov 2007 21:30:22 -0500
Randy Pratt <bsd-unix at> wrote:

> On Fri, 30 Nov 2007 00:47:01 +0000
> John Murphy <freebsd001 at> wrote:
> > Testing 7.0 beta2 so I should upgrade to beta3, but all was working
> > well until I portupgraded yesterday. Now amarok shuts down X server:
> > 
> > Nov 30 00:14:37 asus kdm-bin[1146]: X server for display :0 terminated
> > unexpectedly
> > 
> > I get a couple of lines of text if I start it from an xterm, but they
> > are gone too quick to read. I will upgrade tomorrow, but my question
> > is more: how can I discover which ports were upgraded most recently
> I use a little shell script to find upgrade dates:
> ====
> #!/bin/sh
> cd /var/db/pkg
> list="$(ls -trd */+COMMENT)"
> for item in ${list}; do
>    _date="`stat -f "%Sm" ${item}`"
>    printf "%-25s %s\n" "${_date}" "`echo ${item} | sed 's/\/.*//'`"
> done
> ====
> I can't help with the debug part though.

Very useful script that. Many thanks.

The only ports upgraded at the time were:

Nov 29 01:23:55 2007      samba-3.0.26a_2,1
Nov 29 01:27:05 2007      samba-libsmbclient-3.0.26a_2
Nov 29 01:36:03 2007      xorg-server-1.4_3,1
Nov 29 01:42:21 2007      wxgtk2-2.6.3_5

wxgtk isn't a dependency of amarok so that's ruled out.

With stdout & stderr directed to a file I see lots of variations of:

amarok:       [CollectionDB] [ERROR!] [virtual QStringList SqliteConnection::query(const QString&, bool)]  sqlite3_compile error:
amarok:       [CollectionDB] [ERROR!] index tags_deviceid_index already
amarok:       [CollectionDB] [ERROR!] on query: CREATE INDEX
 tags_deviceid_index ON tags( deviceid ); 

Then just before X dies:

amarok:     [Moodbar] Resetting moodbar: 
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x2b562520 ):
 KAccel object already contains an action name "play_pause"
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout
 for PlaylistWindow/PlaylistWindow
: Fatal IO error: client killed
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary!
 Use amarokapp.
amarokapp: Fatal IO error: client killed
amarok: BEGIN: virtual CollectionDB::~CollectionDB()
amarok: END__: virtual CollectionDB::~CollectionDB() - Took 0.00023s
amarok: [virtual EngineController::~EngineController()]

I tried using 'amarokapp', but the output looks the same to my
untrained eye. 

Had to install mp3blaster (ncurses mp3 player) to play some tunes;
it worked a treat :)

Thanks, John.

More information about the freebsd-questions mailing list