Dreaded '__mb_sb_limit' Error And What To Do About It

Tim Daneliuk tundra at tundraware.com
Sun Nov 25 00:55:21 PST 2007

On one of my FBSD 6-STABLE machines, I have the system cvsup the latest
sources nightly and rebuild (but not install) the system and all
relevant kernels.   Every week or so, I go to single user and
install what was last built (assuming the build worked OK).

My last such venture was on 11-20-2007 without problems.

Tonight, I tried to do this again, and immediately got hit with
the libexec '_mb_sb_limit' symbol missing problem.  I fell back
to the 11-20-2007 system image, and all is once again well.

So, here's my question.  Is this a temporary problem that will be
resolved at some point before 6.3 is released, or do I have have to
rebuild the entire system applications set to get new binaries that
don't depend on this symbol?  Also, if it is going to be fixed, how
will I know it has been before trying another update like this again?


P.S. Rebuilding the apps on this system would be a REAL pain.  Here's
hoping the fine FBSD developers can find it within themselves to
make this symbol once again appear so old binaries will run unchanged.
Tim Daneliuk     tundra at tundraware.com
PGP Key:         http://www.tundraware.com/PGP/

More information about the freebsd-questions mailing list