Problem with startx

Siraj Shaikh siraj.shaikh at
Sat Nov 24 10:48:38 PST 2007

I installed freebsd (6.2) from scratch. Download, updated the ports
tree. Upgraded all the ports. Installed Xorg (it was xorg-7.3). When I
typed in


it worked fine. Then I proceeded to install gnome2-lite using

pkg_add -r gnome2-lite

That worked fine. Tried to start startx/gnome2 (after following the
instructions here: I want gnome2
to start when I type in startx. I have done this in the past, never
had trouble. But when I rebooted and typed in startx, I had a problem

Shared object "" not found, required by "gnome-session"

and then went to UPDATING and performed

portupgrade -r gettext

Now, I try startx, it doesnt work at all. It gives me the same error

Shared object "" not found, required by "gnome-session"

followed by

waiting for X server to shutdown FreeFontPath: FPE
"/usr/local/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing

Please help! All I want to do is to be able to run gnome2.



More information about the freebsd-questions mailing list