FreeBSD-7.0-Beta2 (i386) on Opteron?

Mark Staudinger mstaudinger at
Wed Nov 14 15:06:00 PST 2007

I wasn't sure if -questions or -current was the right group, but I searched
both before posting.

I'm trying to begin testing FreeBSD-7.0-Beta2, and I have a mixture of Intel
and AMD-based machines that I work with.
I'm using the i386 release.  I've previously used FreeBSD-4.9R and 6.2R for
i386 on these machines, but cannot get
7.0-Beta2 to work on the AMD machines.  These are 100- and 1000-series
dual-core Opteron CPUs.

I've tried:
Updating using source from 6.2-Release
Installing from 7.0-Beta2 CD
Installing from 7.0-CURRENT-200710-i386 snapshot CD

I see a variety of errors, including:

1) BTX Halted

2) errors when running /bin/sh from /etc/rc
       /libexec/  Undefined symbol "opterr" referenced from COPY
relocation in sh
       /libexec/ Invalid file format (on multiple binaries)
       various other "undefined symbol" messages
       signal 10, signal 11 on multiple binaries

I've tried both uni-processor and SMP kernels, as well as the GENERIC kernel
supplied with the
base installation.  I've also tried disabling ACPI.  There's no "one error
condition" that I can identify,
it seems to change each time I boot, it's quite erratic, and most errors
don't result in a panic.
I have of course tested multiple pieces of hardware, and I've also performed
the install on an Intel-based machine
and then moved the disk to the AMD.  In all cases, I encountered failures
immediately upon running a few small
commands (assuming the login prompt even appears).

Has anyone successfully used 7.0-Beta2 for i386 on AMD Opteron-based
platform?  Any suggestions for tracking
down the problem?


More information about the freebsd-questions mailing list